Pb mounting Windows 2000 shares

Eduard Pertíñez eduard at pertinez.net
Sat Jul 19 18:42:26 GMT 2003


I don't know if that replies your question but I hope it will reply lots of 
others.

I have RedHat 8.0 + kde 3.1.1 in catalan. Catalan uses very similar characters 
that spanish, french, portuguese or italian, so that surely aplies to a huge 
amount of languages.

In my computer with RedHat I couldn't see any share of any windows computer. 
both smbclient and smb:/ in konqueror refused to let me see any shared 
folder. The little weel in konqueror kept moving and konqueror kept working, 
but it never gave me a page with the folder contents.

I think I someday managed to partially solve it making konqueror use 
libsmbclient.so instead of smbclient.

But I surely upgraded once kde and all changes got erased.

Anyway. The very strange thing was that
a) That happened with my office mandrake box too

and b) I've seen lots of messages of different people all around sayng the 
same but no reply helped.

I explain all these things because I hope people can find this message in the 
archives when they try to solve the same problem.

I found my solution and I hope it is a general one.

My system's default LANG was set to ca_ES.UTF-8

you can check it typing export on your konsole:

You should find a line that looks like:

declare -x LANG="ca_ES.UTF-8"

Ok then. What I did was to change ca_ES.UTF-8 to ca_ES.

export LANG="ca_ES"

Doing this I solved a problem I had with some files with accents not doing 
well.

Then I ran konqueror from the konsole and I saw problems with webpages were 
already solved.

Finally I looked at /etc for files with ca_ES inside and I removed ".UTF-8" 
from them. There were two of them, one on /etc and the other in /etc/X11 
(don't remember the name of them.

Finally I restarted the computer and: voilà, even smb:/ was working.

Hope someone else can check it.

Edu



A Dimarts 01 Juliol 2003 16:43, Matthieu Racine va escriure:
> Hello,
>
> I'm using a SAMBA server (Debian Woddy 3.0 / Kernel 2.4.20) to share files
> between a Windows 2000 and Others Linux servers.
>
> I'm stuck with the following problem :
> When i create Directories/Files using special characters (éàç...) the
> translation is not correct between the systems.
> I've set character set = ISO8859-1 in smb.conf.
> Now the traslation is correct between Windows 2000 using SAMBA shares. BUT
> A linux mounting a SAMBA share has now the problem :
> specials chars are not corrects. Idem for a Linux mounting a Windows 2000
> share.
>
> I've tried
> mount -t smbfs -o
> username=myuser,password=xxxx,iocharset=iso8859-1,codepage=cp850 ... And
> all the charsets/codepages I've found without succes.
>
> Sometime the translation presents a ? other times a :x82 replacing the é.
>
> Please HELP,
>
> thanks.
>
> --
> Matthieu




More information about the smb-clients mailing list