[Samba] could not connect to, Unable to find suitable address - solved
Matthias@gmx.li
matthias.meyer at gmx.li
Mon Nov 17 11:21:50 UTC 2025
Hello 😁️,
I run iptables as a firewall. On the non working server firewalld was installed and activated too.
After removing it all went fine.
Br
Matthias
Am Sonntag, dem 31.08.2025 um 23:16 +0200 schrieb Matthias at gmx.li:
> Yes, I turned it off.
> Thanks a lot - I'll post the solution as soon as I found the reason.
>
> Have a great day
> Matthias
>
> Am Sonntag, dem 31.08.2025 um 10:41 +0100 schrieb Rowland Penny via samba:
> > On Sat, 30 Aug 2025 11:04:30 +0200
> > Matthias--- via samba <samba at lists.samba.org> wrote:
> >
> > > Am Samstag, dem 30.08.2025 um 08:10 +0100 schrieb Rowland Penny via
> > > samba:
> > > > On Sat, 30 Aug 2025 01:38:05 +0200
> > > > "Matthias at gmx.li" <matthias.meyer at gmx.li> wrote:
> > > >
> > > > > Hello :)
> > > > >
> > > > > It is also not working with IP-Adress instead server name.
> > > > > * Firewall is disabled.
> > > > > * winbind isn't installed on any server
> > > > > * I have the same problem with nfs shares😪️
> > > > >
> > > > >
> > > >
> > > > I took another look at your smb.conf for the non working machine and
> > > > saw that I missed something.
> > > >
> > > > You might want to read the section on 'hosts allow' in 'man
> > > > smb.conf'.
> > > >
> > > > This parameter expects either a name or IP and defaults to 'hosts
> > > > allow =' , that is nothing after the '=' and this means that no
> > > > hosts are denied access. Do do you have a computer called 'ALL',
> > > > because that is the only computer that will be allowed access.
> > > >
> > > > Rowland
> > > >
> > > > PS Please do not 'CC' me, just reply to the list.
> > > >
> > > >
> > > Thanks - I changed "hosts allow = ALL" into "hosts allow =
> > > 192.168.0.0/255.255.255.0" and restart smb service.
> > >
> > > But as before:
> > > root at fileserver:~# smbclient -L athlux
> > > lpcfg_do_global_parameter: WARNING: The "encrypt passwords" option is
> > > deprecated lpcfg_do_global_parameter: WARNING: The "domain logons"
> > > option is deprecated protocol negotiation failed:
> > > NT_STATUS_CONNECTION_RESET
> > >
> > > I don't believe it is the samba configuration because I have a
> > > similar issue with NFS. "showmount -e athlux" on athlux lists the NFS
> > > shares "showmount -e athlux" on fileserver returns "clnt_create: RPC:
> > > Unable to receive" athlux can can mount both, nfs-shares as well as
> > > samba-shares from athlux and from fileserver. But fileserver can't
> > > mount anything from athlux
> > >
> > > I can ssh into both machines as I like. So network configuration must
> > > be ok. "iptables -F" disables my firewall.
> > > Maybe there is an service, used by both, samba as well as nfs but not
> > > from ssh. This service could be broken?
> > >
> > > Br
> > > Matthias
> > >
> > >
> >
> > I also do not think that this has anything to do with Samba, if
> > anything it points to a firewall problem, have you tried (temporarily)
> > turning it off on athlux ?
> >
> > Other than that, I do not feel that I can offer any further help on
> > this problem.
> >
> > Rowland
> >
> >
>
More information about the samba
mailing list