[Samba] [EXTERNAL] Re: 4.17.1 rpcd_winreg, rpcd_spoolss and printing

Achim Gottinger achim at ag-web.biz
Wed Oct 4 14:42:12 UTC 2023

Am 02.10.23 um 15:58 schrieb Tim ODriscoll via samba:
>> From: Achim Gottinger <achim at ag-web.biz>
>> I'm having a similar issue. After updating from Debian Wheezy with Samba 4.7.7 to bookworm with samba 4.18.6. On at least two locations printing takes up to 10 minutes and i see alot of rpcd_winreg,
>> rpcd_spoolss processes consuming alot of memory. I can temporary fix it by restarting samba.
>> How did you fix it on your side?
> Hi Achim,
> I cheated and put this is my crontab:
> */30 * * * * killall -o 10m rpcd_winreg
> */30 * * * * killall -o 10m rpcd_spoolss
> Every 30mins, kill all rpcd_winreg and rpcd_spoolss processes that are over 10 minutes old. Worked brilliantly.
> I tried everything I could think of including redeploying GPOs, building a new server and a fresh Windows 11 client. At one point I thought it was only the win10 clients causing it, but then the win11 clients started too.
> Sadly my entire linux estate has now been removed and we've been forced to move to Microsoft's 365 with cloud-based uniFlow for the printing, so I can't try anything else.
> Tim

Thank you Tim,

First I thought it is an memory issue, because the affected systems had low memory (1-2GB). Today an 4GB vm was affected as well. Will try your approach with the cron jobs.


More information about the samba mailing list