[Samba] rpc_pipe_open_ncalrpc: connect(/run/samba/ncalrpc/EPMAPPER) failed: No such file or directory

Rowland Penny rpenny at samba.org
Mon Oct 2 09:06:20 UTC 2023

On Mon, 2 Oct 2023 11:37:00 +0300
Michael Tokarev via samba <samba at lists.samba.org> wrote:

> 01.10.2023 17:04, Rowland Penny via samba wrote:
> > On Sun, 1 Oct 2023 08:41:01 +0300
> > Michael Tokarev via samba <samba at lists.samba.org> wrote:
> > 
> >> This question has already been asked in the past, but there was
> >> no answer.
> >>
> >> The above message is logged quite often
> >> in /var/log/samba/log.samba-dcerpcd. This is a stand-alone
> >> anonymous read-only server.
> >>
> >> Is it something to worry about?  It smells like samba isn't working
> >> properly.
> > 
> > This could be something as simple as the directory being created as
> > '/run/samba/ncalrpc/np/epmapper' and being searched for as
> > '/run/samba/ncalrpc/np/EPMAPPER'. Which may or may not matter,
> > depending on just what is supposed to end up in the
> > 'emapper/EMAPPER' directory. Interestingly, I have
> > '/run/samba/ncalcrpc/np/emapper' and '/run/samba/ncalrpc/EPMAPPER',
> > I wonder if I should ?
> > 
> > To me, this sounds like a bug, should the directory be created as
> > '/run/samba/ncalrpc/np/EPMAPPER' or should it be searched for as
> > '/run/samba/ncalrpc/np/epmapper' ?
> I tried (sym)linking one to the other the first time it happened, - it
> didn't work. I don't remember the error at that time though.  Think it
> was with 4.16 still.  Lemme try it again..

What I was trying to get at was the 'error' is that it seems to search
in uppercase, but it is created in lowercase, one of those must be wrong.
Which, I do not know, mainly because I also have 'EPMAPPER' in

I initially thought they were directories, but a bit more investigation
turned up this from both:

ls /run/samba/ncalrpc/EPMAPPER/
ls: cannot access '/run/samba/ncalrpc/EPMAPPER/': Not a directory
ls -lad /run/samba/ncalrpc/np/epmapper/
ls: cannot access '/run/samba/ncalrpc/np/epmapper/': Not a directory

So, they must, it appears, be files

> >> If yes, how can I fix it?
> > 
> > As a workaround, you could try setting 'log level = 0'.
> Nope, definitely not, - as I wrote before, this message fills in the
> logs and *other* important messages are hidden in the flood as the
> result.  I want to know if something bad happens, not to hide errors,
> - this is why I asked in the first place.  I can change debug level of
> this very message to be something larger than current 0 and recompile,
> *that* would be real workaround.

I didn't think it would work, I just threw it it in as a thought and
placeholder whilst the proper problem was fixed :-(

> But I'd rather find the root cause and fix it instead.

I 'think' the correct fix would be to find where 'epmapper' is being
set to 'EPMAPPER' and fix that, but my 'C' isn't good enough to chase
it down, never mind fix it.
Perhaps you should log a bug report ?

> ...
> > http://www.dcerpc.org/
> > 
> > https://learn.microsoft.com/en-us/openspecs/windows_protocols/ms-rpce/290c38b1-92fe-4229-91e6-4fc376610c15
> > 
> > https://wiki.samba.org/index.php/DCERPC
> I've one name forever associated with samba & dcerpc in my mind -
> Luke Kenneth Casson Leighton.  I think he was the one who created
> dcerpc.org. And he was the strong advocate to rewrite most things
> in samba (samba2 at the time, iirc) to use dcerpc in late 1990s..
> with lots of emails on samba mailing lists, and with a lot of
> resistance around that.  Dunno where he is now..

Wasn't that the guy who tried to fork Samba (Samba-NG ?) after falling
out with the rest of the Samba devs ? Before my time.


More information about the samba mailing list