[Samba] Internal DNS not coming up in 4.18.0

Anantha Raghava raghav at exzatechconsulting.com
Fri Mar 24 09:16:09 UTC 2023


How can I be so foolish? I just can't imagine.

The issue was in smb.conf file. the the server's "netbios name" was 
reading as AD instead of DC, which was the actual host name. Basically I 
had copied contents of smb.conf file from old server to the new server 
and forgot to change the name to actual host name. I went all around 
editing the DNS, checking sam.ldb, other files, configuration and all 
only to finally find that the name was coming because of error in 
"netbios name" in smb.conf. Hence samba-tool domain join and drs 
showrepl were finding the none existent ad.xxxx.com server.

The moment this was corrected everything started working normally. Now 
we are on version 4.18.0

Thanks to community, Rowland in particular for the support and for 
providing pointers.

Thanks & regards,

Anantha Raghava

On 24/03/23 6:49 am, Anantha Raghava wrote:
> On 23/03/23 5:08 pm, Rowland Penny via samba wrote:
>> On 23/03/2023 11:30, Anantha Raghava via samba wrote:
>>> You are right. They are not starting. One of the server is throwing 
>>> NTDS and rid related error and exit. By the way this one was having 
>>> all FSMO roles before it was removed. I haven't tried the other one. 
>>> I will try and & turn of faulty DCs and start the old (second server 
>>> & check. If I can get some good back up from here, will this work?
>> From the sound of it, you only have two options here:
>> 1) you get a good DC from the ones you have turned off, back this up 
>> and then start again.
> I did this and I got the DC up & running with proper SOA records. I 
> did seize all fsmo rolls to this running DC. I also did a dbcheck 
> --cross-ncs --fix and this found 2 errors, basically reference to non 
> existent, old FSMO roles holder and it fixed it. Then I attempted to 
> join the new samba server (samba-version 4.18.0) and this is again 
> saying, "Found writable DC ad.example.com" and connection is refused.
> nslook up reports there is no server ad.example.com, dig reports there 
> is no server ad.example.com, ping is unable to resolve the name. But 
> samba-tool domain join and samba-tool drs showrepl are finding it. I 
> just can't understand from where these two are finding it. There is 
> only a host with name ad.example.com and samba version 4.18.0 is just 
> installed on it.
> Just can't figure out from where samba-tool domain join and drs 
> showrepl are finding the reference.
>> 2) you provision a new domain, this will entail re-joining everything 
>> to the new domain.
>> There may be a third option, you employ a Samba expert to try and fix 
>> your domain, this is beyond a mailing list.
>> See here:
>> https://www.samba.org/samba/support/
>> Rowland

More information about the samba mailing list