[Samba] fruit:copyfile not working as expected

Alexander Harm || ApfelQ alexander.harm at apfelq.com
Thu Mar 2 07:35:31 UTC 2023

Hello Mike,

I know from my customers that moving files under macOS Ventura on a SMB share is a mess and completely broken by Apple (e. g. moved files cannot be opened until you reconnect). Unfortunately I do not have a ZFS-backed machine to test against available right now to confirm the behaviour. Is your order of "vfs objects” correct?

Regards, Alexander

> On Thursday, Mar 02, 2023 at 4:34 AM, Mike Pastore via samba <samba at lists.samba.org (mailto:samba at lists.samba.org)> wrote:
> Hi folks,
> I have a number of Mac users connecting to our Samba fileserver over VPN.
> When they copy/move files between shares it takes quite a long time due to
> our miserable business internet connection. I set fruit:copyfile = yes in
> smb.conf expecting that to enable server-side copy for Mac users.
> Unfortunately, it did not.
> Befuddled, I tried the same copy operation from a Windows VM and it worked
> great. Very little network traffic, direct disk-to-disk copy on the server.
> So the server itself is configured correctly, the backing filesystem (ZFS)
> is configured correctly, etc. The problem must lie between vfs_fruit and
> macOS nsmb.
> I've upgraded Samba to 4.17.5 and tried toggling various other vfs_fruit
> options to see if one of them is conflicting with the copyfile option. No
> quick fixes, I'm afraid. Hopefully somewhere here can point me in the right
> direction—or at least confirm this behavior on Samba 4.16 or newer and
> macOS Big Sur or Ventura.
> Thank you in advance!
> Mike
> --
> To unsubscribe from this list go to the following URL and read the
> instructions: https://lists.samba.org/mailman/options/samba

More information about the samba mailing list