[Samba] Sonos S1 access denied with Samba 4.17

James Youngman james at youngman.org
Wed Jul 19 09:52:17 UTC 2023

I just upgraded from Debian 11 to Debian 12 and now (I think as a
result) my Sonos S1 units cannot play music from my SMB share.

The (updated) version of Samba is 4.17.9, while the version which I
believe previously worked was 4.13.13.

On the Sonos controller (i.e. my phone) I see the error message
"Unable to play '<album name>'  access to ////nas/music denied."

I've captured (see link below) the log file for the affected client
covering just the relevant time period, though I don't know which bit
of the log file would really be illuminating.

If I run (on a local Linux machine)

    smbclient  \\\\\\\\nas\\\\music -N  -U guest -c  'dir james/\*.\*'

Then I get pretty much the output I would expect.  I suppose that the
protocol version being used by smbclient doesn't match that of the
Sonos S1 units, though.

More details:
   * Samba log file: https://pastebin.com/WJaMnpyi
   * smb.conf: https://pastebin.com/BzqyeNrh

>From the Debian changelog I see this, which could be relevant, though
I don't know how relevant it is.

    898   * Notable changes in 4.16 series compared to 4.13:
    904     - SMB1 protocol has been deprecated, some subcommands has
been removed

How can I get this working?   Read-only access is fine.

Thanks for any help.

More information about the samba mailing list