[Samba] Trust relationship login error

Jakob Curdes jc at info-systems.de
Thu Jul 13 09:51:42 UTC 2023

Am 13.07.2023 um 11:05 schrieb Enrico Morelli via samba:
> Dear,
> I've a samba running as domain controller on a Debian 10 server. It's working fine until today.
> Today some Windows 10 Pro client starts to give "Trust Relationship Between This Workstation And The Primary Domain Failed" error during login process.
> The only error in samba logs is: netlogon: NETR_LOGONGETCAPABILITIES failed.
> I tried removing a client from the domain and adding it back in, but I obtain the same result.
> What's happen?
Hello Enrico, the July 2023 Windows update broke something. Can you 
please tell us whether that is a local login at the PC or is it RDP?

Most people only have problems when logging in via RDP. Is this an 
Active Directory domain or an old NT4-style domain?

Currently the only known workaround is to uninstall the July Windows 
update, then everythin works again.

Hope this helps, Jakob

More information about the samba mailing list