[Samba] Print Management Blank After Working for Years

Aaron de Bruyn aaron at heyaaron.com
Mon Jan 23 20:17:05 UTC 2023

Hey everyone,

This caught me by surprise.

I set up printing through Samba over a year ago for better audit logging and ease of isolating printers on to their own VLAN.
It's been working well for a long time.

A month ago I had problems when I upgraded to a newer version of Samba and got things straightened out.

It's been humming along for about a month now with no issues on ~27 member servers.

Last week, one of the local copier companies decided to come out and start replacing copiers with no notice at 5 offices.

I pulled up Print Management, loaded the correct drivers, and those 5 offices were done. Pretty simple.

Today, they showed up to replace copiers at 8 more locations.

I pulled up print management, and all the servers are blank. Nothing listed under printers, drivers, ports or forms—even first 5 offices I set up. Printing is working properly at those offices, and from a new machine, I can connect, automatically install the print driver, and print stuff.

It's like the Print Management console is gorked.

Here are a few things I noticed/tried:
- All machines are running Samba from Debian: 2:4.17.3+dfsg-3~bpo11+1. Tried upgrading one machine to 2:4.17.4+dfsg-3~bpo11+1 with no success
- Ports, Drivers, and Forms are populated correctly when I right-click the Samba server and go to "properties" in the print management console.
- Trying to right-click on Printers and choosing "add" in print management, and on the very last step it complains a printer with that name already exists
- Tried switching from 'rpc_server:spoolss' = external and 'rpc_daemon:spoolssd' = fork to 'rpcd_spoolss:idle_seconds' = 300 and 'rpcd_spoolss:num_workers' = 5 with no success

Running the RPC commands manually appears to work:

root at ussnisdnas01:# rpcclient localhost <http://localhost> -U "REDACTED\adebruyn" -c "enumdrivers"
Password for [REDACTED\adebruyn]:

[Windows NT x86]
Printer Driver Info 1:
Driver Name: [HP Universal Printing PCL 6]

[Windows x64]
Printer Driver Info 1:
Driver Name: [HP Universal Printing PCL 6]

root at ussnisdnas01:# rpcclient localhost <http://localhost> -U "REDACTED\adebruyn" -c 'setdriver "ussnisdcpr01" "HP Universal Printing PCL 6"'
Password for [REDACTED\adebruyn]:
Successfully set ussnisdcpr01 to driver HP Universal Printing PCL 6.
root at ussnisdnas01:# rpcclient localhost <http://localhost> -U "REDACTED\adebruyn" -c "enumprinters"
Password for [REDACTED\adebruyn]:
name:[\\LOCALHOST <http://LOCALHOST>\ussnisdcpr01]
description:[\\LOCALHOST <http://LOCALHOST>\ussnisdcpr01,HP Universal Printing PCL 6,ussnisdcpr01]

root at ussnisdnas01:#

Unfortunately, manually setting the driver doesn't get printing working. It appears to try to install the driver and then says "The print processor does not exist".
I can uninstall the existing drivers for the "old" copier and reconnect to it just fine.

I cranked up debug logging to 8 and don't see anything in /var/log/samba/log.rpcd_spoolss (or the old /var/log/samba/log.spoolssdd).

Any thoughts on what I can look into next?


More information about the samba mailing list