[Samba] Delegation of control failure for any built-in Security Principals

Sorin P. psleo2003 at yahoo.com
Mon Jan 23 12:02:22 UTC 2023

Hi Rowland.
I've just sent a request for the Bugzilla account creation.After I get the account, I'll open the bug.
Thank you.Sorin

   On Monday, January 23, 2023 at 10:03:49 AM GMT+2, Rowland Penny via samba <samba at lists.samba.org> wrote:  

On 22/01/2023 22:21, Sorin P. wrote:
> It is indeed a Python 2 script and I did a few minor changes to make it 
> work with Python 3, and it does.
> However, that's not the root cause for the write failure.
> I still don't understand why SELF can't be selected, considering that on 
> a domain controller which was created with an older Samba version, the 
> same exact steps worked flawlessly (including SELF selection).
> Using that same procedure I was able to successfully delegate the rights 
> for the users to be able to write the ssh key attribute.
> However, on the domain I'm trying the changes now, was provisioned with 
> samba v4.17, and the wizard + SELF selection does not work anymore.

Ah, this is the first time (that I recall) that you have said that it 
worked previously for you, I thought that you were trying to get it to 
work for the first time. On that basis, it could be a regression, or it 
could be the newer Heimdal (did it work on 4.16.x ?), or it could have 
something to do with the numerous changes that have occurred lately.

I suggest you open a bug report.


To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba

More information about the samba mailing list