[Samba] error trying to authenticate from Linux to AD

Gary Dale gary at extremeground.com
Wed Apr 19 20:57:12 UTC 2023

On 2023-04-13 02:11, Christian Naumer via samba wrote:
> Am 12.04.23 um 22:34 schrieb Gary Dale via samba:
>> I've tried it both ways (dc1 and DC1) and get the same result. And 
>> yes, I did restart the krb5-admin-server in between.
> There should not be _any_ krb5-admin-server in your network! Your 
> Samba DC is the Kerberos server not anything else. If this is 
> installed anywhere remove it.
OK, sorry. I was trying something from another wiki to get this to work. 
Removed it but still having the same issue.

To be clear, I'm not a fan of the idea that I need to use AD to 
authenticate Linux users. I've not had to do that in the past whether 
for NT-style domains or AD. Up until the last year, user mapping worked 
fine. I have no real interest in why the Samba developers felt it was 
necessary to remove it. I think it is a blunder to make us all dependent 
on a non-Linux authentication and permissions system simply because we 
have some Windows (virtual) boxes.

More information about the samba mailing list