[Samba] Unable to add Point and Print printers to clients with Windows 8.1 and up

Thomas Keppler winfr34k at gmail.com
Wed Apr 12 22:14:18 UTC 2023

Hi all,

another month another roadblock!

My workaround using the SHARP PostScript driver worked in February, after another round of updates to my new Windows 10 clients in March, it doesn't (for my Windows 8.1 test client it still works). Printing also used to work fine, just FYI. Meanwhile, I've also upgraded to Debian bookworm and with it to Samba 4.17.7, to no avail. The workaround Ingo proposed also sadly didn't work for me, here.

A friend who has a spare Windows Server 2019 AD setup (1x DC, 1x Print Server, 1x Client) just tried this little experiment for themselves. Connecting to the printer, installing the driver etc. works just fine for them. They've used my set of GPOs and my settings for the printer itself, so at least from what can be easily observed, the setup is very close. They will retry with Windows Server 2012 R2, just in case, so that should prove interesting.

I personally now think this is a Samba "bug" where the protocol has slightly changed and Samba is (not) doing something Windows (in combination with the SHARP driver specifically) now expects. Another new Lexmark printer worked without any issues OOTB with my Samba setup across all Windows versions from 7 onward.

Does anyone have a recommendation how to file a useful bug report that someone can use to have a closer look? I'm definitely not deep enough into the SMB protocol trenches that I can go for a bug hunt myself. The good thing is that this problem can be replicated even without having a SHARP printer and with freely available resources.

Thank you, as always.

Thomas Keppler

More information about the samba mailing list