[Samba] Unable to join domain I think.

Rowland Penny rpenny at samba.org
Sat Sep 17 07:11:52 UTC 2022

On 17/09/2022 00:01, Rob Campbell wrote:
> I run this
> [Fri Sep 16 18:59:03] [root at dc02~$] net ads join -U Administrator
> Enter Administrator's password:
> Using short domain name -- HOME
> Joined 'DC02' to dns domain 'home.rob-campbell.lan'
> DNS Update for dc02.home.rob-campbell.lan failed: ERROR_DNS_UPDATE_FAILED

The join has succeeded but it couldn't update the DNS record, this is 
usually caused by a misconfiguration of /etc/hosts.

> I get nothing in any log from the member DC02 or the DC DC01.  None of 
> the logs are even touched around the time that I ran that command.  
> Shouldn't something be logged somewhere?

I do wish you would change that hostname 'DC02', it is terribly confusing..

If you want more logging for the join command, add '-dN' to the end of 
the join command (where 'N' is a number between 1-10, the higher the 
number, the more logging ) e.g.:

net ads join -U Administrator -d3


More information about the samba mailing list