[Samba] samba-tool domain join: Unable to open tdb '/var/lib/samba/private/secrets.ldb': No such file or directory

Michael Tokarev mjt at tls.msk.ru
Mon Oct 31 14:43:56 UTC 2022

31.10.2022 17:20, Michael Tokarev wrote:
> # tdbtool create /var/lib/samba/private/secrets.ldb
> tdb_open_ex: could not open file create: No such file or directory
> Could not open create: No such file or directory
> database not open

It looks like I already come across this strange toolset, and already
worked around it in the past.  http://www.corpit.ru/mjt/tdb.c - here's
a little program to replace whole tdb-tools thing which is actually
useful from command line.  Last updated in 2018, written, iirc, in 2012.

The only thing it lacks, it seems, is tdbbackup/tdbrestore.

But this has nothing to do with the error message I'm seeing, really.
After finally creating this ldb file, this message has gone away.

The domain uid lookup and wbinfo still doesn't work, digging in.


More information about the samba mailing list