[Samba] Samba 4 and GPOs

Bering, Uwe Uwe.Bering at lwv-hessen.de
Fri Oct 28 11:49:27 UTC 2022

Hi togehter,

for each of our 20 schools we run a debian Server (bullseye) with Samba 4.16.5  as primary ad-dc. There's no replication to another dc, there isn't another dc at all in this network.  It worked fine in all demands

Now I tried fort he first time to use the GPOs.
The Installation of a central admx-store worked fine and also the first GPO I applied to a client. 

After some experiments I just encountered an error when invoking gpupdate on the client:

= = = = = = = = = = = = =
The processing of Group Policy failed. Windows attempted to read the file \\domain.local\sysvol\domain.local\Policies\{9CF5E225-C40D-452D-A5CE-0288D40407BA}\gpt.ini from a domain controller and was not successful. Group Policy settings may not be applied until this event is resolved.
= = = = = = = = = = = = =

From the client I can open \\[server]\\sysvol\[domain]\Policies\[guid]\GPT.INI, I have even write access to this location.

Does anybody have an idea to solve this Problem?

Viele Grüße

More information about the samba mailing list