[Samba] I never got my problem with my Samba AD Resolved.

Zombie Ryushu zombie_ryushu at yahoo.com
Wed Oct 26 07:08:16 UTC 2022

I never got my problem with my Samba AD DC Resolved.

Months and months ago, I had an issue where I had a single DC that could 
not Authenticate users due to this error:

$ wbinfo -S S-1-5-21-
failed to call wbcSidToUid: WBC_ERR_UNKNOWN_FAILURE
Could not convert sid S-1-5-21- to uid

or use smbclient and cause this error

session setup failed: NT_STATUS_INVALID_SID

I tried endlessly for months to try and fix it with people on the 
mailing list not really helping me, after much debugging I gave up, and 
just sort of "Lived with the problem."

LDAP and Kerberos still worked and the problem was isolated to just one 
Domain Controller of the three I have. So I just sorta "lived with" the 
problem because LDAP and Kerberos still worked. I'd like to try and 
actually fix the problem. I've posted debugging logs to the mailing list 
to death. Would anyone be willing to work with me?

More information about the samba mailing list