[Samba] Print Server issues (when will it stop)

Luke Barone lukebarone at gmail.com
Thu Oct 20 18:48:13 UTC 2022

Hi List,

I had Samba running as a dedicated print server with CUPS joined to an AD
domain (also hosted on Samba). Print server was working fine until a user
got a new computer, and tried to print to one of the printers. It failed,
so I looked at the Print Management window while logged in as the domain
Administrator account. It is using the same driver as the other Lexmarks,
but not loading the driver.

Strange... I double-click the printer, and it acts like it's a new printer!
It wants me to point to the new driver (which I do), but the Properties
dialog does not include the driver. The other printers did.

Unfortunately, I think I have completely buggered it, as I do not see any
printers listed when I browse to the server, or when using Print
Management. I see the drivers and the single Samba port. CUPS can print to
the printer just fine, and spits out a test page.


        server role = member server
        security = ADS
        workgroup = HARW
        realm = HARW.AD.EXAMPLE.CA

        interfaces = lo enp1s0
        bind interfaces only = yes

        log file = /var/log/samba/%m.log
        log level = 1

        # Default ID mapping configuration for local BUILTIN accounts
        # and groups on a domain member. The default (*) domain:
        # - must not overlap with any domain ID mapping configuration!
        # - must use an read-write-enabled back end, such as tdb.
        idmap config * : backend = tdb
        idmap config * : range = 70000-99999

        # Use idmap_rid for domain accounts
        idmap config HARW : backend = rid
        idmap config HARW : range = 100000-199999

        # Configure winbind
        winbind nss info = template
        template shell = /bin/false
        template homedir = /home/harw/%U
        winbind separator = /

        # Enable extended ACLs globally
        vfs objects = acl_xattr
        map acl inherit = yes
        store dos attributes = yes

        client signing = mandatory
        server signing = mandatory

        # Turn off NetBIOS, since our clients don't need it
        disable netbios = yes

    # Printing support
    rpc_server:spoolss = external
    rpc_daemon:spoolssd = fork
    printing = CUPS
    spoolss: architecture = Windows x64
#    rpcd_spoolss:idle_seconds=75
#    rpcd_spoolss:num_workers = 10
    spoolssd:prefork_min_children = 10
    spoolssd:prefork_max_children = 50
    spoolssd:prefork_spawn_rate = 5
    spoolssd:prefork_max_allowed_clients = 500
    spoolssd:preform_child_min_life = 60

    printcap name = /var/run/cups/printcap
    printcap cache time = 60

    path = /var/spool/samba/
    printable = yes

    path = /usr/local/share/printer_drivers/
    read only = no

I tried installing from Debian Backports to see if the issue was fixed, but
that did not make any change.

# smbd --version
Version 4.16.5-Debian

I have also tried letting it sit for 15 minutes, no change. I have rebooted
the admin computer, and the server, with no change. I am at a loss. What do
I need to try next?

More information about the samba mailing list