[Samba] issue joining domain and now logging in

Andrew Bartlett abartlet at samba.org
Wed Oct 12 18:38:36 UTC 2022

On Wed, 2022-10-12 at 20:21 +0200, Diego Franchini via samba wrote:
> this is an extract from my post on superuser and serverfault. I've
> been
> suggested to seek help here too.

Unless the omnipresent Rowland is active there, then I don't think you
will find community Samba support anywhere else but this mailing list
(other than commercially). 

> I'm constantly trying new solutions, literally anything I can find
> online,
> but to this day nothing has completely fixed it.

I think this is mistake number 1.  Lots of constant churn is not
normally a great debugging technique.  I've often seen folks say 'samba
doens't work on Arch, so I rebuilt on Ubuntu', or the same for Fedora
and Debian.  (To be clear, no poor implication intended on any of these
fine distributions). 

Samba normally 'just works', so it is worth investigating carefully and
making changes, recorded, slowly.

First, do you use windows 11 22H2 as a client?

Have you tried with Samba 4.16 or later?

This looks like:

Andrew Bartlett

Andrew Bartlett (he/him)       https://samba.org/~abartlet/
Samba Team Member (since 2001) https://samba.org
Samba Team Lead, Catalyst IT   https://catalyst.net.nz/services/samba

Samba Development and Support, Catalyst IT - Expert Open Source

More information about the samba mailing list