[Samba] Repacking database from v1 to v2 / Samba failed to prime database, error code 22

Andrew Bartlett abartlet at samba.org
Thu Oct 6 08:36:12 UTC 2022

On Thu, 2022-10-06 at 09:58 +0200, Arnaud FLORENT wrote:
> Hi Andrew
> i run in place upgrade test successfully
> thank you
> i also run samba-tool dbcheck --cross-ncs --fix successfully after 
> upgrade as you suggested
> it report a new error type:
> ERROR: incorrect instanceType part of Binary DN binary component for 
> msDS-HasInstantiatedNCs
>   but all errors were fixed.


> could you please explain why those dbcheck errors were not reported when 
> i run samba-tool dbcheck with samba 4.3?
> may be extra check where added between 4.3 and 4.13?

Yes, a lot of extra checks were added between these releases, fixing
issues as we came to know about them.

> should i be worried about those errors? could they happen again?

No, most of these checks are fixing issues introduced in the DB by the
old code, not some random corruption.  That is, when we find an issue
in the database we fix the code that caused it and write a dbcheck test
to fix existing databases.

> could those errors impact AD perfs on Samba 4.3?

No, these are not performance related.

> thanks again for your support

I'm glad to be of assistance.

Andrew Bartlett

Andrew Bartlett (he/him)        https://samba.org/~abartlet/
Samba Team Member (since 2001)  https://samba.org
Samba Developer, Catalyst IT    https://catalyst.net.nz/services/samba

More information about the samba mailing list