[Samba] Broken Dependencies?

samba at laurenz.ws samba at laurenz.ws
Tue Nov 29 16:27:12 UTC 2022


i tried now 4.17.1 from backports, but still there are panics that happen only on rapsberry pi

[2022/11/29 17:23:28.242346,  0] ../../source4/samba/process_prefork.c:443(prefork_restart)
  prefork_restart: Restarting [kdc] pre-fork worker in (10) seconds
[2022/11/29 17:23:37.941916,  0] ../../source4/samba/process_prefork.c:520(prefork_restart_fn)
  prefork_restart_fn: Restarting [kdc] pre-fork worker(2)
[2022/11/29 17:23:37.988288,  0] ../../lib/util/fault.c:173(smb_panic_log)
[2022/11/29 17:23:37.991412,  0] ../../lib/util/fault.c:174(smb_panic_log)
  INTERNAL ERROR: Signal 11: Segmentation fault in pid 8607 (4.17.3-Debian)
[2022/11/29 17:23:37.993196,  0] ../../lib/util/fault.c:178(smb_panic_log)
  If you are running a recent Samba version, and if you think this problem is not yet fixed in the latest versions, please consider reporting this bug, see https://wiki.samba.org/index.php/Bug_Reporting

-----Ursprüngliche Nachricht-----
Von: Michael Tokarev <mjt at tls.msk.ru> 
Gesendet: Donnerstag, 2. Juni 2022 08:18
An: Dirk Laurenz <samba at laurenz.ws>; 'Andrew Bartlett' <abartlet at samba.org>; 'sambalist' <samba at lists.samba.org>
Betreff: Re: [Samba] Broken Dependencies?

02.06.2022 07:45, Dirk Laurenz wrote:
> HI,
> thanks for the input. Does this problem also happen on amd64? Or are the backports working there?

So far it only happens on your armhf machine. I run amd64 bpo11 version on a few of our machines just fine, many others use it too.  I *think* it is something arch-specific, and it should be the same for "regular" bookworm build too.  That's why I wanted to try it on a virtual machine.

Maybe there's also something specific to your configuration, too.


More information about the samba mailing list