[Samba] Unable to access shares after upgrade to version 4.17.3

Michael Tokarev mjt at tls.msk.ru
Wed Nov 23 14:20:23 UTC 2022

23.11.2022 00:21, spindles seven via samba wrote:

> OK got over that problem by following the advice above, but now am getting:
> Some packages could not be installed. This may mean that you have
> requested an impossible situation or if you are using the unstable
> distribution that some required packages have not yet been created
> or been moved out of Incoming.
> The following information may help to resolve the situation:
> The following packages have unmet dependencies:
>   ldb-tools : Depends: libldb2 (>= 1.1.5) but it is not going to be installed
>               Depends: libtalloc2 (>= 2.3.4~) but 2.3.1-2+b1 is to be installed

Unfortunately you didn't tell which command line produced this output.
I *guess* you're trying to install samba=2:4.17.3+dfsg-2~bpo11+1
winbind=2:4.17.3+dfsg-2~bpo11+1.  Nope, this doesn't work.

> Have tried commenting out the bullseye-backports line in /etc/apt/sources.list but same result.    Tried adding -t bullseye/samba-4.17/ to the apt-get install command:
> root at goflex:~/samba# apt-get install -t bullseye/samba-4.17/ samba samba-dsdb-modules samba-vfs-modules winbind libpam-winbind libnss-winbind libpam-krb5 smbclient ldb-tools cifs-utils libnss-winbind libpam-winbind
> but comes up with the error:
> E: The value 'bullseye/samba-4.17/' is invalid for APT::Default-Release as such a release is not available in the sources
> How to resolve this?

apt install -t bullseye/samba-4.17 samba

(or whatever packages you want to install).

Actually this is a bit fun, I don't know why
it ended up to be like this.  It should have
"mjt" there somewhere, I think :)


More information about the samba mailing list