[Samba] Unable to access shares after upgrade to version 4.17.3

Michael Tokarev mjt at tls.msk.ru
Tue Nov 22 20:45:33 UTC 2022

22.11.2022 23:02, spindles seven via samba wrote:

> Am trying to install from your repository but am failing at the first hurdle:
> I have imported your key using:
> gpg --keyserver keyring.debian.org --recv-keys 6EE195D1886E8FFB810D4324457CE0A0804465C5

btw, my key is included into debian-keyring package too.

> (don't know where that went as it didn't produce a separate file in /usr/share/keyrings)

It went to ~/.gnupg/, - now you have to export it from there.

> but still getting:
> E: The repository 'http://www.corpit.ru/mjt/packages/samba bullseye/samba-4.17/ InRelease' is not signed.

> So I tried putting [sign-by=/usr/share/keyrings/debian-keyring.gpg] in the mjt.list file like this:
> deb [signed-by=/usr/share/debian-keyring.gpg] http://www.corpit.ru/mjt/packages/samba bullseye/samba-4.17/

It is not debian-keyring.gpg it is debian-maintainers.gpg.

But please don't do that: I don't know how exactly this sign-by= works with
keyrings having multiple keys, - should it be signed by all of them or any of them?

> tried debian-maintainters.gpg with the same result.


> What am I doing wrong?

  gpg --export-key 6EE195D1886E8FFB810D4324457CE0A0804465C5 > mjt.key
  cp mjt.key /etc/apt/mjt.key (or whatever, - using /tmp is not a good idea ;)
  add signed-by=/etc/apt/mjt.key to the deb line (it is signed-by, not sign-by -
    see sources.list manpage).

Or you can extract the same key from debian-maintainers.gpg file you found
already - it's the same there and received from keyring.debian.org.

I probably should write whole thing in the README.
Ubuntu automates all this in its ppa thing nicely
(when actually using a PPA on launchpad).


More information about the samba mailing list