[Samba] Unable to mount with cifs.mount, but file browser mount...

L. van Belle belle at samba.org
Thu May 26 21:21:07 UTC 2022

I think your hitting a bug here and I think David has a point on the kernel. 

I have a wheezy mounted with cifs to latest windows, but I must say, 
I recompiled a buster kernel (4.19) for it and a 4.6.16 samba to make it work.

Try set in the stretch server smb2 as minimal protocol, but I think you already tried that and add the real after the loginname. 
mount.cifs //VDMSV1.AD.FVG.LNF.IT/Users/gaio /mnt --verbose -o username=gaio at AD.FVG.LNF.IT

The version differences might hit old bugs in kerberos also 
The idea on that is this part. 
Password for gaio@//VDMSV1.AD.FVG.LNF.IT/Users/gaio  

note the @ here.. 

If that doesn’t work try these options on the mount. 
 noserverino,vers=3.0 and/or 2.0 

if these options don’t work, then you need a better kernel, the samba versions should be good enough.
my wheezy uses cifs-utils 2:5.5-1, check that also. 

On the automount, where my nfs version worked great, my cifs version is currently read only. 
but it does automount, not fixed yet, since I only needed ready only in this case and was in rush.
There is a post on the list that works with autofs, if you found it again.. cc me.. 😉 
I searched but couldn’t find it that quickly so that’s why I run read only. 

Hope this helps and give you few ideas but best one is, upgrade stretch to buster at least. 
It does help a lot..  



> -----Oorspronkelijk bericht-----
> Van: samba <samba-bounces at lists.samba.org> Namens David Mulder via
> samba
> Verzonden: donderdag 26 mei 2022 20:37
> Aan: samba at lists.samba.org
> Onderwerp: Re: [Samba] Unable to mount with cifs.mount, but file browser
> mount...
> On 5/26/22 1:59 AM, Marco Gaiarin via samba <samba at lists.samba.org>
> wrote:
> >
> > I'm a but puzzled.
> >
> > File server: debian stretch, louis packages 4.10.18+dfsg-0.1stretch1,
> > AD domain, same samba revision.
> >
> > Client: mint ulyssa, aka ubuntu focal, samba 4.13.17~dfsg-0ubuntu0.21.04.2
> .
> >
> >
> > Client configured with Kerberos, winbind, nss/pam; i can login into
> > client with domain credential, flawlessy.
> > After login, i can run 'caja' (Mate file manager) and mount shares
> > from the server.
> >
> >
> > But i need als to automount some dirs (also homes), so i've setup
> > pam_mount; that does not work. But seems that cifs.mount does not work
> at all:
> >
> > 	root at archimede:~# mount.cifs
> //VDMSV1.AD.FVG.LNF.IT/Users/gaio /mnt --verbose -o username=gaio
> > 	Password for gaio@//VDMSV1.AD.FVG.LNF.IT/Users/gaio:
> **********
> > 	mount.cifs kernel mount options:
> ip=,unc=\\VDMSV1.AD.FVG.LNF.IT\Users,user=gaio,prefixpath=gaio,
> pass=********
> > 	mount error(13): Permission denied
> > 	Refer to the mount.cifs(8) manual page (e.g. man mount.cifs) and
> > kernel log messages (dmesg)
> >
> > and in log:
> >
> > 	[ 3285.806313] CIFS: Attempting to mount
> //VDMSV1.AD.FVG.LNF.IT/Users/gaio
> > 	[ 3285.806358] No dialect specified on mount. Default has changed to
> a more secure dialect, SMB2.1 or later (e.g. SMB3), from CIFS (SMB1). To use
> the less secure SMB1 dialect to access old servers which do not support
> SMB3 (or SMB2.1) specify vers=1.0 on mount.
> > 	[ 3285.822830] CIFS VFS: cifs_mount failed w/return code = -13
> >
> > I've tried every combination of 'vers=' and 'sec=' but no one works...
> >
> >
> > What i'm missing? Thanks.
> >
> >
> Maybe your server doesn't support SMB1? Also, SMB1 support can be
> compiled out of the kernel now. Maybe you have an SMB1 server and an
> SMB2+ kernel?
> --
> To unsubscribe from this list go to the following URL and read the
> instructions:  https://lists.samba.org/mailman/options/samba

More information about the samba mailing list