[Samba] NT4 Roaming Profiles

Andrea Venturoli ml at netfence.it
Wed Jun 15 10:18:08 UTC 2022

On 6/8/22 18:17, Robert Steinmetz,,, via samba wrote:
> I have an NT4 Domain which has Roaming Profiles Configured. Recently I 
> have been getting error messages on the Windows 10 clients that the 
> roaming profiles are not completely loading. I have checked the .V6 
> profiles are being created. The relevant appropriate portions of my 
> smb.conf file are:
>          logon path = \\REMUS\profiles\%U
>          logon home = \\REMUS\%U
>          logon drive = U:
>          domain logons = Yes
> Note that the pats and home directories are on a different server than 
> the PDC. This has worked for me in the past.

In my experience Roaming Profiles have never worked vaguelly fine.
With Windows 10, it's even worse, as, as you say, they never completely 
load (althoug this is mostly a non critical error).

AFAICT, the reason lies in the permissions of the AppData\Roaming folder 
where UWP apps are stored: there seems to be some files there for which 
the user has no write permission, so loading the profile can't overwrite 

Sorry to be so imprecise, but I have no Windows machine at hand now. 
Check the client's Event Viewer and you'll see the relevant messages.


More information about the samba mailing list