[Samba] SMB Multi Channel only working in one direction

sighunter at gmx.de sighunter at gmx.de
Tue Jun 14 12:31:40 UTC 2022

Hi all,

this is the first time I use mailing lists, so please be forgiving. I'm trying to get everything right.
I'm not sure this is a bug, probably a misconfiguration on my end somewhere

About 2 years ago I switched my NAS server from Windows Server to Gentoo with Samba.

The NAS Server has 4 x 1Gbit Ethernet cables to the network switch and my client PC with Windows 11 has 4 x 1Gbit Ethernet cables to the same network switch.
All 8 interfaces are in the same IPv4 subnet ( and get their IPs via DHCP from the router. They also have IPv6 addresses.

samba ~ # smbd --version
Version 4.16.1
Kernel  5.17.14-gentoo-dist-hardened

The DNS configuration looks like this: https://dpaste.com/E5NY2WYA4
(fqdn resolves to all the 4 IPs)

My smb.conf.

My smbstatus -d3

My problem:

Whenever I copy a file from the client PC to the samba server it uses 4 interfaces on the NAS and 4 interfaces on the client PC, like I would expect, and with awesome speed:

However when I copy a file from the samba server to the client PC (opposite direction) it only uses 1 interface on the server side.
I see in windows task manager that all 4 interfaces on the client PC are equally utilized (about 200 mbit/s) but iftop on the samba server shows no traffic at all on 3 of 4 interfaces

Multi Channel from Windows Server to Windows 10 was working in all directions, so in general I think my hardware should be capable.
All transfers were done from SSD to SSD, so disk speed should not be the issue.

What I tried so far:

all interfaces on same subnet, all interfaces on different subnets,
disabled ipv6, disabled ipv4,
limited the interfaces in smb.conf in various combinations, tried setting aio read and write size = 1 because internet is full of that but IMHO should not be needed,
many many restarts of the NAS and PC to rule out any side effects and make everything "fresh",
tried to set static routes for some reason,
tried with ksmbd and it happens there too

I am currently out of ideas why this happens and only in one direction.

Any other logs or configs required to troubleshoot? Any hints what else to look for?

Thank you for your support!!



More information about the samba mailing list