[Samba] Strange Bind freezing

Nikita Druba admin at npo-lencor.ru
Tue Feb 1 00:28:14 UTC 2022

Hi again!

I found the stage, where named freezing and why its started after adding 
a new DC:


When I tried to run this command from terminal, the named freezed. My 
smb4.conf has the next line:

nsupdate command = /usr/local/bin/nsupdate -g

I tried to change parameter of command to -o or set it without parameters,

I tried also special port dns/samba-nsupdate and:

nsupdate command = /usr/local/bin/samba-nsupdate -g

But result of all my tries - now named guarantied freezing when I run 
samba_dnsupdate --all-names.

I tried to compiled named with Heimdal from ports and "base", but the 
same result.

This problem "successfully" repeated at my other FreeBSD DC. At openSUSE 
DC samba_dnsupdate by nsupdate (even with -g) just getting "permission 

The line, that solved my situation:

dns update command = /usr/local/sbin/samba_dnsupdate --use-samba-tool

Also, when I switched to built-in dns, samba_dnsupdate worked fine.

Any suggestions?

More information about the samba mailing list