[Samba] Some older windows clients can't connect after upgrade

Emmanuel Florac eflorac at intellique.com
Fri Dec 16 08:54:03 UTC 2022

Le Thu, 15 Dec 2022 11:51:03 +0100
Emmanuel Florac via samba <samba at lists.samba.org> écrivait:

> After upgrading to samba 4.13 (from debian oldstable to debian
> stable), some windows clients (windows 2008r2 and lower, Indows 7,
> windows XP, etc) can't connect to the serveur anymore. My first move
> was to enable SMBv1, now some linux clients connect using the older
> protocol, but the windows client still fail to connect "can't
> connect" error, neither using the UNC name, nor the IP adress;
> neither from the windows explorer, or "net use //xxxx/yyy" in a CMD
> shell.
> Any ideas?

Some more tests:

"wbinfo -u" lists correctly the domain users.
"getent passwd" only lists local users (is it OK?), but
"getent passwd <some domain user>" works properly.

We tried "net ads leave" and "net ads join", it works fine, and nothing
changes: the machines that could connect previously still can, those
that couldn't still can't. We rebooted everything of course, no dice.

Using a local account from the server (vs an AD account) works. So
there's something wrong about authentication in the AD, but I don't
understand what's wrong.

Emmanuel Florac     |   Direction technique
                    |   Intellique
                    |	<eflorac at intellique.com>
                    |   +33 1 78 94 84 02
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 195 bytes
Desc: Signature digitale OpenPGP
URL: <http://lists.samba.org/pipermail/samba/attachments/20221216/9f532394/attachment.sig>

More information about the samba mailing list