[Samba] Samba support for Sonos S1 versions 4.15 and above

Jeremy Allison jra at samba.org
Tue Dec 13 18:12:56 UTC 2022

On Tue, Dec 13, 2022 at 09:44:30AM -0800, Nelson Minar wrote:
>   Thank you for your attention on this Sonos / Samba problem; it's been very
>   frustrating! The blame lies squarely with Sonos refusing to update their
>   old client but it'd be nice if Samba kept supporting them anyway.
>   Do I understand correctly; Samba built from source is working but not
>   Ubuntu's builds? Have you tried a built-from-source version on Ubuntu
>   22.10?
>   As you suggested I just tried using a login with password, not guest
>   access, and it also fails. All 3 logins work fine with smbclient but not
>   from Sonos.
>   I also captured some Samba logs from various failed login attempts on the
>   Sonos with different usernames and passwords. See here:
>     [1]https://gist.github.com/NelsonMinar/38489bdc425003f593d0449dd966f401
>   The samba logs don't seem to show the cause of the problem. All I see at
>   log level 2 is "connect to service musicshare initially as user nobody"
>   followed immediately by "closed connection to service musicshare". There's
>   a second file in the gist that's a log level 10 capture. I'm not capable
>   of understanding that level of detail but nothing obvious leapt out at me.
>   (I had a previous theory this might be related to SSL changes, deprecating
>   old insecure clients. That's the situation with Adobe's Node SMB server
>   and Sonos. But these logs show a connection is being established and bytes
>   are flowing, so maybe that's not it.)

I see the problem. The old version of the SONOS software
(Linux kernel cifsfs) wants to use a UNIX extensions
info level : SMB_QUERY_FILE_UNIX_BASIC      0x200
and the new Samba you're using has UNIX extensions
turned off by default.

Try setting:

"unix extensions = yes"

in the [global] section of your smb.conf.

More information about the samba mailing list