[Samba] Set printer driver on 4.16.2 does not work

Peter Varkoly peter at varkoly.de
Wed Aug 3 09:54:09 UTC 2022


I have problem to set the printer driver with rpc (resp  cupsaddsmb) 
with 4.16.2. The same way has worked on 4.15.5:
I've tried it as Administrator and as user with SePrintOperatorPrivilege 
privilegs as member of the group "Print Operators".

rpcclient printserver -N -A /tmp/01c1c62ebd2ec -c 'adddriver "Windows NT 

The ad Server is a samba-4.16.2 too.
The printserver confiugration is:
workgroup = PRICSKE
netbios name = printserver
printing = CUPS
security = ADS
bind interfaces only = yes
interfaces =
load printers = no
min domain uid = 0
pid   directory = /run/sambaprintserver
cache directory = /var/lib/printserver
lock  directory = /var/lib/printserver/lock
state directory = /var/lib/printserver
private directory = /var/lib/printserver/private
rpc_server:spoolss = external
rpc_daemon:spoolssd = fork

comment = Printer Drivers
path = /var/lib/printserver/drivers
read only = No

path = /var/tmp/
printable = yes
printer name = pr1
hosts allow =

The ad-server configuration is:
netbios name = admin
workgroup = PRICSKE
dns forwarder =
server role = active directory domain controller
idmap_ldb:use rfc2307 = Yes
check password script = 
bind interfaces only = yes
interfaces =,
ntlm auth = yes
template shell = /bin/bash
ldap server require strong auth = no
load printers = no
printcap name = /dev/null
disable spoolss = yes
hosts deny =

path = /var/lib/samba/sysvol
read only = No

comment = Network logon
path = /var/lib/samba/sysvol/pricske.iskola/scripts
root preexec = /usr/share/cranix/plugins/share_plugin_handler.sh 
netlogon open %U %I %a %m pricske.iskola
read only = No

Do you have any hints for me?


More information about the samba mailing list