[Samba] Unable to join domain

Rob Campbell robcampbell08105 at gmail.com
Mon Oct 11 17:52:03 UTC 2021

/etc/hosts:   localhost
::1         localhost fsdc02.dc01.test-server.lan fsdc02 DC02

# systemctl start smbd nmbd winbind
Failed to start smbd.service: Unit smbd.service is masked.
Failed to start nmbd.service: Unit nmbd.service is masked.
Failed to start winbind.service: Unit winbind.service is masked.

# net ads join -U administrator
Enter administrator's password:
Using short domain name -- DC01
Joined 'FSDC02' to dns domain 'dc01.test-server.lan'
DNS Update for fsdc02.dc01.test-server.lan failed: ERROR_DNS_UPDATE_FAILED

[Mon Oct 11 12:51:56] [root at fsdc02~$] netstat -tulpn | egrep
[Mon Oct 11 12:51:58] [root at fsdc02~$]

[Mon Oct 11 12:51:58] [root at fsdc02~$] host dc01.test-server.lan
dc01.test-server.lan has address
[Mon Oct 11 12:56:02] [root at fsdc02~$] host domain name pointer dc01.test-server.lan.

search dc01.test-server.lan

On the first dc I used internal samba for DNS.  On the second dc, I pointed
to the first for DNS.  Do I need to run an additional DNS server?  I'm able
to resolve internal and external hosts.

I tried to mimic the wiki so SAMDOM = DC01 & DC1 = DC1 & EXAMPLE.COM =
TEST-SERVER.LAN just so I can keep everything in order because I was
getting confused with all my other attempts.  I want my domain just to be
test-server.lan and then DC01 would be the first and FSDC02 would be the
second but just to get this working so that I understood, I tried to mimic
the wiki.

I wanted DC01 to be test-server.lan so host test-server.lan and host
dc01.test-server.lan would resolve the same and fsdc02 would resolve to
fsdc02.test-server.lan and dc02.test-server.lan.

In all things, Be Intentional.

On Mon, Oct 11, 2021 at 11:44 AM Patrick Goetz via samba <
samba at lists.samba.org> wrote:

> On 10/11/21 10:08, Rowland Penny via samba wrote:
> > On Mon, 2021-10-11 at 09:54 -0500, Patrick Goetz via samba wrote:
> >> Maybe another thing to work on for the next release?  <:)
> >>
> >> Or is there a technical reason why this isn't possible?
> >
> > It is because only ntp or chrony know anything about 'mssntp' and
> > 'ntp_signd'
> >
> >>   I've long ago
> >> stopped installing ntp on anything under normal conditions, since
> >> systemd-timedated just works.
> >
> > 'systemd-timedated' only knows 'sntp' so you cannot use it with AD. It
> > isn't Samba that needs updating to use systemd-timedated, it is
> > systemd-timedated that needs updating to work with Samba AD.
> >
> Got it, thank you. Then I'd rather they keep systemd as simple as
> possible and I'll just install ntp when necessary.
> > Rowland
> >
> >
> >
> --
> To unsubscribe from this list go to the following URL and read the
> instructions:  https://lists.samba.org/mailman/options/samba

More information about the samba mailing list