[Samba] RODC update/upgrade

Ilias Chasapakis forumZFD chasapakis at forumZFD.de
Fri Oct 8 09:20:41 UTC 2021

Dear Andrew,

Thank you for your answer.

On the second part of my description you may see that the dbcheck on the
ADDC from which I forced replication was checked and free from errors
(only "notes").

> Checked 2000 objects (0 errors) 

While I am happy that I should not be so concerned, it would be helpful
if there was not just an error reported, but a clue given on what it is
and where it is.

If you read again the second part of the original post, the problem is
exactly that I don´t know what the problem is because it is not
verbosely reported anywhere. If I pipe the fix output in a file and then
search for errors there is no trace.

So to recap:

- I do dbcheck --fix and all records are processed

- The output is "Checked 2000 objects (1 errors)" with suggestion to run
with --fix again

- I run it again and now only "Checked 2000 objects (1 errors)" without
suggestion to re-run fix

- I re-run with --fix and get "Checked 2000 objects (1 errors)" with
suggestion to run with --fix again

So you enter a loop. And the error is not reported anywhere to my
knowledge (the output is directly the error in parenthesis, nothing in
the process) so my question is where else should I look other than the
output of the dbcheck command.

I am surely OK with it working correctly anyway, but would be nice to
understand what the origin of this could be (e.g. that as an RODC it
receives replication with data of all our DC infrastructure and then
being a read only resource cannot fix some of the records for some reason?)

Thank you once again for your time.


Am 07.10.21 um 19:01 schrieb Andrew Bartlett via samba:
> On Thu, 2021-10-07 at 17:44 +0200, Ilias Chasapakis forumZFD via samba
> wrote:
>> Hello,
>> I did a minor upgrade on an RO DC from 4.14.7 to 4.14.8 following the
>> instructions from the wiki for the "in place" one, but for AD DC.
>> I had run samba-tool dbcheck before upgrade and got no errors. Then I
>> did the upgrade and then after a post upgrade dbcheck I found that
>> nearly all records were signed as to fix. Did use dbcheck --fix and
>> all
>> records started scrolling during check and were eventually reported
>> as
>> fixed.
>> Checking back again I was surprised to find that it reported checked
>> all
>> records and (1 errors) between parenthesis. Tried again with --fix.
>> The
>> erros stays between parenthesis. I checked if I had login problems to
>> the RO DC from a client and noticed no strange behaviour.
>>> samba-tool dbcheck --fix
>>> Checking 2000 objects
>>> Checked 2000 objects (1 errors)
> What is the error?  Not all errors can be fixed.  If you can't find it
> I wouldn't worry, most Samba DBs have errors and on the RODC dbcheck is
> going to have a harder time fixing a lot of things, I would run that on
> your full DC also.
> Andrew Bartlett
Entschieden für Frieden|Committed to Peace

Ilias Chasapakis
Referent IT | IT Consultant

Forum Ziviler Friedensdienst e.V.|Forum Civil Peace Service
Am Kölner Brett 8 | 50825 Köln | Germany

Tel 0221 91273233 | Fax 0221 91273299 |

Vorstand nach § 26 BGB, einzelvertretungsberechtigt|Executive Board:
Oliver Knabe (Vorsitz|Chair), Sonja Wiekenberg-Mlalandle, Alexander Mauz
VR 17651 Amtsgericht Köln

Spenden|Donations: IBAN DE37 3702 0500 0008 2401 01 BIC BFSWDE33XXX

-------------- next part --------------
A non-text attachment was scrubbed...
Name: OpenPGP_signature
Type: application/pgp-signature
Size: 665 bytes
Desc: OpenPGP digital signature
URL: <http://lists.samba.org/pipermail/samba/attachments/20211008/451894ba/OpenPGP_signature.sig>

More information about the samba mailing list