[Samba] Building v4.15 with glusterfs VFS module, still possible?

Anoop C S anoopcs at samba.org
Wed Nov 17 04:30:57 UTC 2021

On Tue, 2021-11-16 at 13:43 +0100, Jaap van Wingerden via samba wrote:
> I've been trying to build v4.15 from source on ubuntu 20.04, since i
> need
> gluster support. According to the documentation (
> https://www.samba.org/samba/docs/current/man-html/vfs_glusterfs.8.html
> ) it
> should still be available. But compiling with --enable-glusterfs
> builds no
> glusterfs.so.
> I tried modifying source3/modules/wscript_build to hard code
> glusterfs to
> enabled, but compilation fails looking for glusterfs/api/glfs.h . I
> even
> tried downloading the gluster source (v9) and linking that to the
> apropriate folder, but then compilation fails with errors about too
> many
> arguments.

As Jeremy mentioned in the other reply, you need to install GlusterFS
development package(glusterfs-dev) to have those headers files present
at standard locations where Samba will look for during compilation.

Anoop C S

More information about the samba mailing list