[Samba] samba-tool issue

Rommel Rodriguez Toirac rommelrt at nauta.cu
Mon May 31 16:24:29 UTC 2021

El 31 de mayo de 2021 11:50:22 GMT-04:00, Rowland penny via samba <samba at lists.samba.org> escribió:
>On 31/05/2021 16:17, Rommel Rodriguez Toirac via samba wrote:
>>   Hello all;
>> I have some issue with samba4 ADDC in my network. I realized of it
>>   When I run the samba- tool command I have this:
>> ___________
>> root at gtmad1 samba]# samba-tool
>> ERROR(<class 'ImportError'>): uncaught exception -
>/usr/local/samba/lib/private/libcli-smb-common-samba4.so: version
>`SAMBA_4.13.2' not found (required by
>>    File "/usr/local/samba/bin/samba-tool", line 45, in <module>
>>      retval = cmd._run("samba-tool", subcommand, *args)
>>    File
>line 259, in _run
>>      cmd = self.subcommands[cmd_name]
>>    File
>line 36, in getitem
>>      fromlist=['cmd_%s' % attr]),
>>    File
>line 23, in <module>
>>      from samba import provision
>>    File
>line 76, in <module>
>>      from samba.ntacls import setntacl, getntacl, dsacl2fsacl
>>    File
>"/usr/local/samba/lib64/python3.6/site-packages/samba/ntacls.py", line
>35, in <module>
>>      from samba.samba3 import libsmb_samba_internal as libsmb
>> __________
>>   This Server run samba4.14.3
>What red-hat version is this ?
>How did you compile Samba ?
>What packages did you install to compile Samba ?

 Thank for write me back;

[root at gtmad1 private]# cat /etc/centos-release
CentOS Linux release 8.3.2011

./configure --sbindir=/sbin/ --sysconfdir=/etc/samba/ --mandir=/usr/share/man/ --with-systemd --systemd-install-services --enable-debug -p -j2
make install

dnf install flex

dnf install docbook-style-xsl gcc gdb gnutls-devel gpgme-devel jansson-devel keyutils-libs-devel krb5-workstation libacl-devel libaio-devel libarchive-devel libattr-devel libblkid-devel libtasn1 libtasn1-tools libxml2-devel libxslt lmdb-devel openldap-devel pam-devel perl perl-ExtUtils-MakeMaker perl-Parse-Yapp popt-devel python3-cryptography python3-dns python3-gpg python36-devel readline-devel rpcgen systemd-devel tar zlib-devel

dnf install python3-markdown

 The curious is that it worked well a few days ago.
 I think like an system updates broke something... but what?
Rommel Rodriguez Toirac
rommelrt at nauta.cu

More information about the samba mailing list