[Samba] Windows 10 cannot connect without SMB1

Rowland penny rpenny at samba.org
Mon Mar 1 17:52:07 UTC 2021

On 01/03/2021 17:18, K. R. Foley wrote:
> On 3/1/21 11:06 AM, Rowland penny via samba wrote:
>> On 01/03/2021 16:29, K. R. Foley wrote:
>>> Is there a way to run a command  on the server (ie. smbclient) that 
>>> will tell what protocols are supported?
>> Easiest way would be to run on the DC:
>> smbclient -L localhost -N
>> The last line of the output should be:
>> SMB1 disabled -- no workgroup available
>> I wonder if your problem is down to a lack of encryption ? Try adding 
>> 'smb encrypt = enabled' to the smb.conf on the DC.
>> After this, I am running out of ideas.
>> Rowland
> Yes. I had already tried that. See below.
> [root at ss-prod kr]# smbclient -L localhost -N
> Anonymous login successful
>     Sharename       Type      Comment
>     ---------       ----      -------
>     sysvol          Disk
>     netlogon        Disk
>     IPC$            IPC       IPC Service (Samba 4.11.13)
> SMB1 disabled -- no workgroup available

Well at least it shows that your DC is not using SMBv1, so why does your 
Windows client think it is ?

> Additionally, I also tried adding 'smb encrypt = enabled'. No change.

It was just a thought.

I think this is looking like a dns problem on your Windows client or at 
least a Windows problem. You have this in the log you posted:

NetUseAdd to \\ss-prod.local.richardshapiro.com\IPC$ returned 384

IPC$ is a hidden Samba share that is required for Samba to function and 
'384' means it isn't secure.

Try running this on the DC: smbclient //ss-prod/IPC$ -UAdministrator

After entering the password, you should find yourself at a prompt:

Try "help" to get a list of possible commands.
smb: \>

Press 'q'  to exit


More information about the samba mailing list