[Samba] Windows 10 cannot connect without SMB1

K. R. Foley kr at cybsft.com
Mon Mar 1 17:18:46 UTC 2021

On 3/1/21 11:06 AM, Rowland penny via samba wrote:
> On 01/03/2021 16:29, K. R. Foley wrote:
>> Is there a way to run a command  on the server (ie. smbclient) that 
>> will tell what protocols are supported?
> Easiest way would be to run on the DC:
> smbclient -L localhost -N
> The last line of the output should be:
> SMB1 disabled -- no workgroup available
> I wonder if your problem is down to a lack of encryption ? Try adding 
> 'smb encrypt = enabled' to the smb.conf on the DC.
> After this, I am running out of ideas.
> Rowland
Yes. I had already tried that. See below.

[root at ss-prod kr]# smbclient -L localhost -N

Anonymous login successful

     Sharename       Type      Comment
     ---------       ----      -------
     sysvol          Disk
     netlogon        Disk
     IPC$            IPC       IPC Service (Samba 4.11.13)
SMB1 disabled -- no workgroup available

Additionally, I also tried adding 'smb encrypt = enabled'. No change.


More information about the samba mailing list