[Samba] Failed to connect lsa server when trying to create a domain trust

Emilian Mitocariu mitocariu.emilian at gmail.com
Wed Jun 30 08:00:37 UTC 2021


I'm trying to create a domain trust between a Windows server 2019 AD with
domain level 2016 and forest level 2012 R2 (let's call it win.local) and a
Samba 4.7.6 (Ubuntu 18.04) AD with domain and forest level 2008 R2 (let's
call it sam.local)

When I run: samba-tool domain trust create win.local --type=external
--direction=both and other variations of it, I always get this error:

ERROR: REMOTE_DC[dc1.win.local]: failed to connect lsa server -
ERROR(0xC000020D) - The transport connection has been reset.

oaad-dc7.oaad.local resolves to the right IP and the DCs I'm trying to
create the trust between are in the same network, so there should not be
any restrictions between.

Another colleague tried before me to create the trust with the AD Domains
and Trusts tool which failed with the error: "The security ID structure is

Does anyone have any idea why this happens and how can I fix it?

More information about the samba mailing list