[Samba] samba-tool issue

Rowland penny rpenny at samba.org
Thu Jun 10 06:52:34 UTC 2021

On 10/06/2021 02:04, 市川@フォーミックス via samba wrote:
> Hello.
> I was also bothered  just a while ago.
> my CentOS8.4 and Ubuntu20.04 same Error.
> I installed 4.14.5 to same 4.13.9 folder (override).
> Unupdated library suspected of malfunctioning.
>    CentOS8: /usr/local/samba/lib64/python3.6/site-packages/samba/samba3/libsmb_samba_internal.cpython-36m-x86_64-linux-gnu.so
>    Ubuntu20.04: /usr/local/samba/lib/python3.8/site-packages/samba/samba3/libsmb_samba_internal.cpython-38-x86_64-linux-gnu.so
> Remove or Rename to '.so.old'  (and ldconfig), It improved.
> Or It may be solved by installing in a new folder instead of overwriting.
> --
> TakIchikawa

This is an artefact of building your own Samba into a directory. Samba 
from time to time removes libs etc, if you then compile a new version of 
Samba over an earlier version, the removed code is not deleted from disk 
and you can get an error. If you must compile Samba yourself, then I 
would advise replacing the entire OS e.g. if Samba is running as a DC, 
join a new DC to replace the old one.


More information about the samba mailing list