[Samba] rsync copy operation fails on a CIFS mount

SZIGETVÁRI János jszigetvari at gmail.com
Fri Jul 30 10:52:28 UTC 2021

Dear Members,

I work for a company that (among others) sells Ubuntu-based log storage
appliances. I ran into a problem, where I'm trying to copy a large amount
of data over to a CIFS mount from a Ubuntu 18.04 based appliance to a
Windows 2012 R2 Storage Server, and rsync fails after 1-2-3 hours into the
copy operation with something like:
rsync: failed to set times on "FILENAME.U5EgGX": No such device (19)"

and I see a number of kernel logs just prior to that, that look like this:

kernel: [3819786.441711] CIFS VFS: No task to wake, unknown frame received!
NumMids 1
kernel: [3819786.441717] 00000000: 6c000000 424d53fe 00000040 00000000
 ...l.SMB at .......
kernel: [3819786.441718] 00000010: 00000012 00000001 00000000 ffffffff
kernel: [3819786.441720] 00000020: ffffffff 00000000 00000000 00000000
kernel: [3819786.441721] 00000030: 00000000 00000000 00000000 00000000
kernel: [3819786.441722] 00000040: 00000000

Now who should I turn to get to the end of this problem?
Should I file a bug for the Samba project? Or is it the kernel code that
may be affected? If that is the case, who should I turn to?

I also tried to google around for a while, and I found the same exact
package hexdump on the linux-cifs mailing list from 2012:

In that thread the person reporting the problem failed to reproduce the
problem a few weeks after reporting it.
There it was recommended to try and mount the share with SMB v1, but that
is out of the question nowdays.

We tried forcing the mount to happen with vers=3 and 3.02, but it made no

Best Regards,
János Szigetvári
RHCE, License no. 150-053-692

LinkedIn: linkedin.com/in/janosszigetvari

__ at __˚V˚
Make the switch to open (source) applications, protocols, formats now:
- windows -> Linux, iexplore -> Firefox, msoffice -> LibreOffice
- msn -> jabber protocol (Pidgin, Google Talk)
- mp3 -> ogg, wmv -> ogg, jpg -> png, doc/xls/ppt -> odt/ods/odp

More information about the samba mailing list