[Samba] WORKGROUP/Samba cannot be viewed in list in Other Locations

Dr. Makoto Sakurai makotosakurai18yokohama at gmail.com
Tue Jul 27 11:30:19 UTC 2021

Dear Samba developers,

I sent this report to the Nautilus/GNOME mailing list, but I cannot obtain
suitable information.

The way to reproduce this problem is

1 .workgroup=WORKGROUP in Windows 10 PC is prepared. Private networks and
sharing files/printers are enabled. Network searching is also enabled.

2. Open the Nautilus in the Ubuntu 21.04.

3. See the other location: One can not see the Windows PC even though one
selects Windows networks. (One can see smb://IPaddress in direct at the
location bar. But one can not see the list beforehand.)

I tried the same thing after upgrading from Ubuntu 20.04 and the workgroup
appeared for the first time but again disappeared. (I tried to apt-get
remove --purge samba and apt-get install samba). I tried to change
/etc/samba/smb.conf like

netbios name = samba-printer
server min protocol = SMB3
client min protocol = NT1
printing = CUPS
log level = 2
log file = /var/log/samba/log.%m
max log size = 1024

, but it doesn't work.

I don't know what to do. I reopened the Windows 10 PC's firewall, but the
situation doesn't change.

Note that the smbclient -L WindowsPCaddress works fine. It might be a
problem with Nautilus (or SMB's nmblookup?). Also, the
firewalld/ufw/iptables are disabled for this purpose.

Is there any information for this problem? I googled on the web, and there
are some similar reports, but they were neglected in the mailing lists.

Sincerely yours,

Makoto Sakurai

More information about the samba mailing list