[Samba] CIFS share disconnects on Linux client, but is still accessible via SMBCLIENT

Gene Poole landrlatz at free.fr
Sun Jul 18 17:23:25 UTC 2021

Well I've removed everything you suggested I remove, except for "debug 
timestamp" since I seem to need that, and I'm still getting the same 
results: the share mounts at boot, disappears after maybe 20 minutes, 
but can still be accessed with smbclient. If I unmount and try to 
remount I get "no such file or directory."

I've disabled SMBv1 in Windows. Re your mount suggestion, I have no dns 
set up on the Windiws box. My dns is my modem-router. According to 
Windows my FQDN ("Full Computer Name") is just "ETHIQUABLE".

Looking at the samba log, I see something that seems odd - 
"Authentication for user [alarm] -> [alarm] FAILED with error 
NT_STATUS_NO_SUCH_USER, authoritative=1"

I've created a user called "alarm" (the base user on my Linux box) on 
the Windows machine and assigned him the same _samba password_ I've 
assigned on the Linux box - which is NOT the same as "alarm"'s Linux 
password (which is how I understood things were supposed to be set up).

I can send part of the samba log if you want. Thanks very much for your 
help so far.

On 17/07/2021 18:24, Rowland Penny wrote:
> On Sat, 2021-07-17 at 17:58 +0200, Gene Poole via samba wrote:
>> Hello and thanks for answering. Here's the current mount line from
>> fstab:
>> //192.168.x.xx/Work /mnt/Work cifs
>> noperm,_netdev,credentials=/home/alarm/.smbcredentials,iocharset=utf8
>> ,gid=1000,uid=1000,file_mode=0777,dir_mode=0777,vers=1.0
>> 0 0
> Samba 4.12.3 doesn't use SMBv1, so you should probably remove
> 'vers=1.0'
>> and here's smb.conf:
> You might as well remove these, they are default settings:
> #client max protocol = SMB3
> #local master = yes
> #guest account = nobody
> #large readwrite = yes
> #follow symlinks = yes
> debug timestamp = yes # I left this because I wasn't getting a human-readable time in the log(?)
> You can probably remove these as well, unless you have a valid reason
> to keep them:
> #domain master = yes # should be 'auto' the default
> #preferred master = yes # should be 'auto' the default
> #os level = 255 # why ? this isn't a BDC and a BDC shouldn't be that high
> #password server = None # you really should remove this
> #guest ok = yes # this should only be in a share
> #map to guest = Bad Password # why ? if you want guest access, use 'bad user'
> #socket options = TCP_NODELAY IPTOS_LOWDELAY SO_KEEPALIVE # Why ? you should rely on the kernel
> #wide links = yes # why ?
>>    ----------(I've left off the configurations for the shares on the
>> Linux box)------------
> Pity, it might have helped to see at least one share
>> Note that the Windows host currently has both SMB1 and SMB2 enabled.
> I suggest you disable SMBv1
>> I've already tried using the server name instead of the path in the
>> mount line.
> Have you tried the FQDN ? is dns set up ?
>> Let me know if you want to see anything from the samba log as well.
> Try the suggested changes first
> Rowland

More information about the samba mailing list