[Samba] CIFS share disconnects on Linux client, but is still accessible via SMBCLIENT

Rowland Penny rpenny at samba.org
Sat Jul 17 16:24:43 UTC 2021

On Sat, 2021-07-17 at 17:58 +0200, Gene Poole via samba wrote:
> Hello and thanks for answering. Here's the current mount line from
> fstab:
> //192.168.x.xx/Work /mnt/Work cifs 
> noperm,_netdev,credentials=/home/alarm/.smbcredentials,iocharset=utf8
> ,gid=1000,uid=1000,file_mode=0777,dir_mode=0777,vers=1.0 
> 0 0

Samba 4.12.3 doesn't use SMBv1, so you should probably remove

> and here's smb.conf:

You might as well remove these, they are default settings:

client max protocol = SMB3
local master = yes
guest account = nobody
large readwrite = yes
follow symlinks = yes
debug timestamp = yes

You can probably remove these as well, unless you have a valid reason
to keep them:

domain master = yes # should be 'auto' the default
preferred master = yes # should be 'auto' the default
os level = 255 # why ? this isn't a BDC and a BDC shouldn't be that
password server = None # you really should remove this
guest ok = yes # this should only be in a share
map to guest = Bad Password # why ? if you want guest access, use 'bad
should rely on the kernel
wide links = yes # why ?
>   ----------(I've left off the configurations for the shares on the 
> Linux box)------------

Pity, it might have helped to see at least one share

> Note that the Windows host currently has both SMB1 and SMB2 enabled. 

I suggest you disable SMBv1
> I've already tried using the server name instead of the path in the 
> mount line.

Have you tried the FQDN ? is dns set up ?

> Let me know if you want to see anything from the samba log as well.

Try the suggested changes first


More information about the samba mailing list