[Samba] CIFS share disconnects on Linux client, but is still accessible via SMBCLIENT

L.P.H. van Belle belle at bazuin.nl
Thu Jul 15 13:26:39 UTC 2021

You might need to provide the option vers=1.0 option to the mount command to force version SMB1 



> -----Oorspronkelijk bericht-----
> Van: samba [mailto:samba-bounces at lists.samba.org] Namens 
> Lestrad via samba
> Verzonden: donderdag 15 juli 2021 14:46
> Aan: samba at lists.samba.org
> Onderwerp: [Samba] CIFS share disconnects on Linux client, 
> but is still accessible via SMBCLIENT
> Hello. My Wandboard running Arch Linux ARM mounts a cifs 
> share hosted on 
> a Windows 7 machine at boot. After a certain amount of time the 
> connection to the share is lost. I can cd to the mount point 
> directory, 
> but when I run ls I get the error message: "cannot open 
> directory '.': 
> Host is down". If I unmount the mount directory and try to 
> remount the 
> share, I get a "mount error(2): No such file or directory" error.
> However, I can still connect to the share using smbclient. And if I 
> reboot the Linux box the share again mounts with no problem. 
> But after a 
> time it becomes inaccessible again.
> I've tried several different things on the Windows machine, including 
> enabling and disabling SMB v1 and trying all the possible 
> settings for 
> the NIC (Intel with the latest driver) and for Windows share 
> permissions. But the problem must involve Linux, since the 
> share remains 
> available via smbclient and mounts with no problem when I 
> reboot. I've 
> updated samba to the latest version and enabled winbind. I'm not sure 
> what else to try.
> Any help would be appreciated. I can provide any information anyone 
> might need.
> Les
> Arch Linux ARM version 5.7.2-1-ARCH
> samba v 4.12.3
> CIFS v 2.26
> mount.cifs v 6.10
> -- 
> To unsubscribe from this list go to the following URL and read the
> instructions:  https://lists.samba.org/mailman/options/samba

More information about the samba mailing list