[Samba] Unable to config "fruit:nfs_aces"

Mikhail Emelchenkov m at emelchenkov.pro
Sun Jul 4 16:57:47 UTC 2021


I am unable to make permissions works properly SMB share from macOS (macOS 10.13 client connects to Ubuntu 20 SAMBA server).

My smb.conf:
fruit:aapl = yes
vfs objects = catia fruit streams_xattr
# (below option is “yes” by default, and I need this option, I will not set it to “no")
fruit:nfs_aces = yes

The issue:
From macOS in Terminal:
$ cd /Volumes/share1
$ touch 123
$ touch -m 123
$ chmod 444 123
$ touch -m 123
touch: 123: Permission denied

So, after changing file to read-only I cannot change its attributes (i.e. time). Synchronisation software built specially for macOS do not work, I cannot backup/sync my files on such shares. I tried to contact engineers of one of commercial sync. product I plan to use, they are not familiar with SAMBA and cannot help. They may add some workarounds but it will take huge amount of time, so I hope it could be fixed by config setting.  On APFS (local FS of macOS) above commands works without error (can change attributes of a r/o file).

I tried to add acl_xattr module, but it breaks permissions. Also, I don’t use ACL anyway.

How to avoid this “permission denied” error, is it possible?


More information about the samba mailing list