[Samba] Printer sharing with my VM

serando serando at sunrise.ch
Thu Jul 1 06:39:41 UTC 2021

Configuration as follows:
-Linux Host 64 bit
-VirtualBox with Windows 7 guest (32bit)
-VirtualBox with host-only adapter

-My printer is connected to the PC via USB cable and works well in Linux.

Goal: Use the printer also in the Windows 7 guest via Samba.

If I install Windows 7 without updates, printing works as expected.

On the other hand, after I have installed all updates, printing in 
Windows 7 no longer works (only test printing).

This is what happens in my Windows 7 VM with all updates:
Immediately after installing the printer in Windows 7 and installing the 
driver in Windows 7, you have the option to make a test print. When I 
make this test print, 2 printer jobs are generated in the Windows queue. 
(-> strange: One print - 2 print jobs)

1st print job:
Doc-Name: Test-print
status: printed (This status is wrong, this job was not printed)
owner: D
pages: 1/1
size: 141 KB

2nd print job:
Doc-Name: Test-print
status: " " (empty)
owner: d (here a lower case letter; in print job 1 a capital letter; 
pages: N/V
size: 320 KB

The second print job is forwarded to the Linux host and printed.
The first print job remains in the Windows queue.

If I print from a windows programme (for example windows editor) instead 
of making a test print, then only one print job is created that looks 
like the first one (see above). And it gets stuck in the Windows queue. 
It does nothing print.

What I have already tried:

-> None of this has worked.

Isn't it strange, that printing works in my Windows 7 guest that has no 
Windows updates?
Isn't it strange, that printing from a Windows programme does no more 
work when I have made all Windows updates, but the test print still works?

Would appreciate some help. Thank you.

More information about the samba mailing list