[Samba] Problem with Home folders

Stephen Atkins satkins at mdwainwright.ca
Thu Jan 21 17:01:22 UTC 2021

Hello everyone.  I'm finally putting together a new AD-DC at work.  My 
main DC is a Windows Server 2019.  I have another server with Arch and 
Samba and it's joined to the domain as a member.  I'm trying to get 
Users home directories working properly.  I followed the guide at 
https://wiki.samba.org/index.php/Windows_User_Home_Folders and things 
where going well.  When I changed a users profile to have the home dir, 
the directory would show up.  When I logged in as that user it was hit 
or miss as to whether I could access that folder.  Some folders are 
accessible by everyone.  It's just not consistent in what permissions it 
applies to the directory.

My share in smb.conf is:

    comment = Private User Files
    path = /UserData/Users
    vfs objects = shadow_copy2
    shadow:format = @GMT_%Y.%m.%d-%H.%M.%S
    shadow:sort = desc
    shadow:snapdir = /UserData/.Userssnapshots
    writable = yes
    force create mode = 0600
    force directory mode = 0700
    printable = no

One of the directories looks like this:
  0 drwxrws---+ 1 mdadmin domain users    0 Jan 21 09:39 dcampbell

Windows permissions:
Allow - MD Admin - Full Control
Allow - Everyone - None
Allow - Domain Users - Full Control

Inheritance is enabled.

I've tried disabling inheritance and it just switches back.  I've tried 
adding users and groups and they disappear when I clock apply.

But then on other directories everything works fine and I can add/remove 

I'm kinda at a loss as to why this might be happening.  Thanks for the help.


More information about the samba mailing list