[Samba] Unable to join domain?

Dan Egli dan at newideatest.site
Sat Feb 6 22:27:27 UTC 2021

On 2/6/2021 1:51 PM, Rowland penny via samba wrote:
> On 06/02/2021 20:43, Dan Egli wrote:
>> I tried the -k, and no go. If I just put -k at the end it says -k 
>> needs a paramater. Looking in the man page it says -k KERBEROS, so I 
>> did, and now samba-tool says "samba-tool dns zonecreate: error: 
>> invalid -k option value: KERBEROS"
>> I am completely unfamiliar with Kerberos, so if this is a stupid 
>> mistake, forgive me.
> No, it is not a stupid question, for 'KERBEROS' read 'no|yes|auto', so 
> to use kerberos with your command you need a ticket (which will be 
> 'krb5cc_0' in /tmp) and to add '-k yes' to the command.
> Rowland

Well, I tried with -k yes and still not working:

#  samba-tool dns zonecreate janus.eglifamily.name 
10.168.192.in-addr.arpa -k yes
Failed to bind to uuid 50abc2a4-574d-40b3-9d66-ee4fd5fba076 for 
ERROR: Connecting to DNS RPC server janus.eglifamily.name failed with 
(3221225473, '{Operation Failed} The requested operation was unsuccessful.')

# klist
Ticket cache: FILE:/tmp/krb5cc_0
Default principal: Administrator at EGLIFAMILY.NAME

Valid starting     Expires            Service principal
02/06/21 13:12:17  02/06/21 23:12:17 krbtgt/EGLIFAMILY.NAME at EGLIFAMILY.NAME
         renew until 02/07/21 13:12:10
02/06/21 15:25:06  02/06/21 23:12:17 

I'm open to the next suggestion.

More information about the samba mailing list