[Samba] Unable to join domain?

Dan Egli dan at newideatest.site
Fri Feb 5 22:18:15 UTC 2021

# net join -U Adminisrator%%<PASSWORD>
Failed to join domain: failed to find DC for domain EGLIFAMILY - The 
object was not found.

# kinit administrator
kinit: krb5_parse_name_flags: unable to find realm of host Athena

Athena is the machine I'm trying to join into the domain, while Janus is 
the machine I ran samba-tool domain provision on.

Here's my smb.conf for Athena - Sans comments. Not much besides printers 
yet because I wanted to get the machine joined, THEN establish the shares.

    workgroup = eglifamily
    server string = Athena
    server role = member server
    hosts allow = 192.128.10. 192.168.43. 127.
    log file = /var/log/samba/log.%m
    max log size = 50
    realm = eglifamily.name
    wins server =
    wins proxy = yes
    dns proxy = yes

    comment = Home Directories
    browseable = no
    writable = yes

    comment = All Printers
    path = /var/spool/samba
    browseable = no
    guest ok = no
    writable = no
    printable = yes

On 2/5/2021 3:08 PM, Rowland penny via samba wrote:
> On 05/02/2021 21:45, Dan Egli via samba wrote:
>> I just setup a new domain controller after a power surge blew through 
>> the suppressor and fried the old one. AS far as I know, I did 
>> everything correct. But now when I try to join a machine to the 
>> domain it fails, claiming the username or password is incorrect.
>> # net join -U Administrator%%<PASSWORD> -S janus.eglifamily.name  
>> (note: internal domain only, not internet connected)
>> Failed to join domain: failed to lookup DC info for domain 
>> 'EGLIFAMILY' over rpc: The attempted logon is invalid. This is either 
>> due to a bad username or authentication information.
>> But I KNOW the password I specified is correct! I wrote the password 
>> down when I provisioned the domain using samba-tool domain provision. 
>> So I'm at a HUGE loss as to what's going wrong. I've looked on the 
>> internet, but apparently my GoogleFu isn't strong today.
>> Please Help?
>> -- 
>> Dan Egli
> Try it without the '-S'
> If that doesn't work, try 'kinit administrator' as root, then 'klist' 
> again as root, you should have Administrators ticket.
> Still not working, check your setup starting with dns.
> Rowland

More information about the samba mailing list