[Samba] Strange Bind freezing

Nikita Druba admin at npo-lencor.ru
Sat Dec 4 07:21:40 UTC 2021

02.12.2021 7:50, Daniel O'Connor пишет:
>> On 2 Dec 2021, at 16:16, Nikita Druba via samba <samba at lists.samba.org> wrote:
>> I  forgot to add, that config of new DC jail, zfs, named and samba fully the same as old DC and very similar for several other my samba DCs. I tried to switch on Internal DNS and back. I also tried to disable all Bind options, that no refers in samba wiki. I do not understand, where else I can found some information, what here is wrong.
> I would try ktrace'ing the bind process, eg...
> sudo -u bind ktrace -f /tmp/named.ktr named -g <rest of options>
> Then reproduce and sift through the trace looking for bad things..
> sudo kdump -f /tmp/named.ktr
> Unfortunately ktrace is pretty low level (since it traces syscalls) but you might get a hint.
I tried to collect some logs by ktrace and catched freeze moment. After 
last from usual log(when Bind freezing), in kdump starts many times 
repeating the next records:

  36460 named    CALL  nanosleep(0x7fffffffea30,0)
  36460 named    RET   nanosleep 0

What can it means?  What do you thing - its a question of Bind or FreeBSD?

More information about the samba mailing list