[Samba] Strange Bind freezing

Rowland Penny rpenny at samba.org
Thu Dec 2 12:10:32 UTC 2021

On Thu, 2021-12-02 at 14:06 +0300, Oljas Kuzembaev via samba wrote:
> On 02.12.2021 12:32, Rowland Penny via samba wrote:
> > There have been numerous problems with running
> > an AD DC using ZFS on Freebsd reported on here, mainly caused by
> > ZFS
> > using nfsv4acls, which a Samba AD DC doesn't really understand. I
> > tried
> > (sometime ago) to provision a domain on Freebsd using ZFS and I
> > couldn't get it it work satisfactorily, perhaps it is time to try
> > again. Using Freebsd as a fileserver is a different kettle of fish,
> > it
> > probably will work, but I haven't tried it.
> I would rather say it is lack of information about samba on zfs, that
> is 
> to blame

You could be correct, but whichever way you look at it, at the moment
there appears to be a problem with running a Samba AD DC on Freebsd,
mainly because of ZFS. Earlier Freebsd versions used the NTVFS
filesystem, which is now only used for running various tests.


More information about the samba mailing list