[Samba] Strange Bind freezing

Oljas Kuzembaev oljas at oml.su
Thu Dec 2 11:06:43 UTC 2021

On 02.12.2021 12:32, Rowland Penny via samba wrote:
> There have been numerous problems with running
> an AD DC using ZFS on Freebsd reported on here, mainly caused by ZFS
> using nfsv4acls, which a Samba AD DC doesn't really understand. I tried
> (sometime ago) to provision a domain on Freebsd using ZFS and I
> couldn't get it it work satisfactorily, perhaps it is time to try
> again. Using Freebsd as a fileserver is a different kettle of fish, it
> probably will work, but I haven't tried it.

I would rather say it is lack of information about samba on zfs, that is 
to blame

not the OS or FS. I am running couple of domains on FreeBSD for almost 
10 years

and had no issues, except my misconfigurations or lack of them. Yes the

initial domain promotion is not smooth, resulting in bad acls on sysvol. 
But this

issue is minor, I just added linux dc temporary, copied sysvol from 
there. Had

no issues with sysvol since. However I have not tried Bind with samba yet.

More information about the samba mailing list